Selections
In Polydraw, most actions work on the current selection (all the vertices & triangles selected), or on everything if nothing is selected. To select items, either click on an object in the “Objects List”, or select the vertices & triangles individually by hitting “S” on your keyboard to change to selection mode, and drag a rectangle around the vertices & triangles you want.

You can also hold the “Control” key (or “Ctrl” key) as you click on individual vertices in the “Vertices List” & “Triangles List”, or holding the “Control” key as you right-click near vertices in any of the views.

Edit Modes
There are 5 different editing modes, as shown in the “Edit Mode” menu. The helpbar on the bottom shows the different operations you can do in each mode. For example, in “Move” mode, dragging the left mouse button around will move the view. However, if you hold down the “Control” key on your keyboard, dragging the left mouse button around will move the currently selected vertices (or all vertices if nothing is selected).

The basic functions of each mode are:

  • Edit mode (hit 'E'): Move individual vertices.
  • Select mode (hit 'S'): Make a selection of vertices & triangles by dragging left mouse button.
  • Zoom mode (hit 'Z'): Change an object's size, or zoom a view in & out.
  • Move mode (hit 'M'): Move an object, or a view.
  • Rotate mode (hit 'R'): Rotate an object.

Basic Tutorial
To create 2 cubes, side by side

  • Create a new document (click on File→New, or hit 'Ctrl' and 'N')
  • Insert a cube (click on Insert→Insert Cube, or hit 'I' then 'C').

The whole cube will automatically be selected.

  • Change to Zoom mode (click on Edit Mode→Zoom, or hit 'Z')
  • Hold down the “Control” key on your keyboard, press the left mouse button somewhere in a 2D View (Top, Front or Side View), and hold the button down while you drag the mouse up a little. The cube should be about half the size it started.
  • Change to Move mode (click on Edit Mode→Move, or hit 'M')
  • Hold down the “Control” key on your keyboard, press the left mouse button somewhere in the “Front View”, and hold the button down while you drag the mouse a little, until the cube is on the left hand side of the Front View.

Since the cube is already selected, make a copy of it by pressing Edit→Copy and then Edit→Paste (hit 'Ctrl' and 'C', then 'Ctrl' and 'V'). There should now be a second cube in the centre of the Front View. Note: Whenever you Paste an object, Polydraw automatically changes to 'Move' Mode.

  • Hold down the “Control” key while you drag the new cube to the right side of the Front View.
  • The “Objects List” shows that there are 2 objects (both cubes). To change the name of the 'Clipboard Object', double click on it or hit 'Enter'. Type in a new name, such as '2nd Cube'.
  • It should be obvious now that there are 2 cube objects. To change the color of a cube, click on that cube in the Objects List (to select it's vertices & triangles), then hit 'C' (or click on Color→'Set Triangle Colors'). You should see a color selection window. Click on the color you want. (For a large color range, click on 'Define Custom Colors').
  • To set the colors of the front face of a cube, change to Select mode (hit 'S', or click on Edit Mode→Select).
  • In the Top View, hold down the left mouse button slightly above & to the left of the bottom left corner of one of the cubes, and drag the mouse to below the bottom right corner of the cube, and release the mouse button.

If you selected some triangles, the 3D View should show the selected triangles as shaded, while the rest are just a wireframe. If you didn't select the face properly, just try again. * Change the face's color (hit 'C', or click on Color→'Set Triangle Colors').

Making a House
This tutorial explains how to work at the vertice / triangle editing level. This is the most basic drawing level, but is not necessarily the easiest or quickest, depending on what you are trying to draw.

  • Create a new file, by clicking 'File→New' (or hit 'Ctrl' & 'N')
  • Insert a new cube, by clicking 'Insert→Insert Cube' (or hit 'I' then 'C')
  • Make the cube a bit shorter but still the same width:

First, change to Zoom mode (click on 'Edit Mode→Zoom', or hit 'Z'). Notice the helpbar at the bottom shows that holding 'Shift' and any mouse button will “Scale the vertices in a direction”.

  • Now hold down the “Shift” key on your keyboard, press the left mouse button in the middle of the Front View, and hold the button down while you drag the mouse up a little.

The cube should be about half the height it started, but with the same width & length.

  • Create a new object for the roof, by clicking 'Edit→Create a new object' (or hit 'N').
  • To change the object's name, double-click on the '<New Object>' in the Objects List on the right of the screen. (If you can't see the Objects List, right-click on a list on the right side of the window, and click on 'Objects List'). For the object's name, type “Roof”.
  • Create a corner for the top of the roof:
  • First change to Edit mode (click on 'Edit Mode→Edit', or hit 'E'). Notice the helpbar at the bottom shows that holding 'Control' and left-clicking will “Plot a new vertice”.

Now hold down the “Control” key on your keyboard, and left-click in the Front View, above the rectangle, on the vertical cross-hair line. This should create an extra vertice at that point.

  • If you look in the other views (3D, Top or Side Views), you should notice that the vertice is at the front of house, but you want it in the middle, to make a pointed roof.

To move it back to the center, left-click in the Top View in the center of the view, to move the vertice there. When in 'Edit' mode, you can always move the current vertice (shown by a red plus sign) by left-clicking in a 2D view.

  • Notice that the vertices aren't shown in the 3D View, because the vertice you just created is selected (shown in the status bar, where it says 'Vertices: 9 (1 selected)').

When there are vertices selected, the 3D View only shows the selected vertice points, rather than all the points. Click on 'Edit→Select None' (or hit the number '0') to de-select all vertices, to show all the vertice points in the 3D View. This will be helpful when creating triangles in the 3D View.

  • Create the first triangle for the roof:
  • First create an empty triangle, by clicking on 'Insert→Add a new Triangle' (or hit 'T'). Now you need to manually set it's corners:
  • While in 'Edit' mode (otherwise, hit 'E'), right-click in the 3D View near the front-top corner of the house. This is probably easier to do in Wireframe view, by clicking on '3D Settings→Wireframe' (or hit '1').

The front-left corner on the top of the house should now have a red plus sign in all views.

  • Now set the first corner of the current triangle to the current vertice by clicking on “Edit→Set polygon's corner” (or hit the 'Spacebar').

If you show the Triangles List (by clicking on 'Lists→Triangles List' or right-clicking in an existing list), you should see that in the last triangle (triangle 13), the first corner is vertice 3 (and the other two corners default to vertice 1).

  • Set the second corner of the triangle, by first right-clicking near the roof vertice, then pressing the 'Spacebar' to set it as the next corner.

You should see a line in each of the views showing there are now 2 corners, and the Triangles List should show the corners as: (3, 9, 1)

  • Set the third corner of the triangle, by doing the same for the front-right corner of the house.

There should now be a triangle for the front of the roof. (Triangle 13 is now vertices 3, 9, 7).

  • To change it's color, click on 'Color→Set triangle colors' (or hit 'C'), and choose a color (click on “Define Custom Colors” for more colors to choose from).

The next triangles created will also be that color. (To change the cube's color, hit 'C' again and choose the color for the cube. Don't forget to hit '0' again to de-select all vertices).

  • Now that you know how to create a triangle between 3 vertices, you should do the same for the 3 other triangles that make up the roof:
  • For each of the 3 remaing walls:
  1. 1 hit 'T' to create an empty triangle.
  2. 2 for each of the 2 top corners of the wall and the roof vertice, right-click on the vertice (in any view) and hit 'Space'.

Making a Waterdrop
This tutorial explains how to work at the vertice / triangle editing level. This is the most basic drawing level, but is not necessarily the easiest or quickest, depending on what you are trying to draw.

  • Click on “File→New” (can press 'Ctrl' & 'N') to start a new file.
  • We need to create the outline for the curve of the Water-drop, which can then be Swept (rotated) around the vertical Y axis (down the middle of the Front View), to create the 3D Waterdrop shape.
  • To create an empty object, click on “Edit→Create a New Object” (can simply press 'N'). Press 'Enter' (or 'Return') to change the name of the new object. Type in something like 'Control Points'.
  • To create a new curve, click on “NURBS Curve→Create a new curve” (or simply press 'U').
  • Now you need to create the curve's control points, which give the curve its shape:
  • Click on “Edit Mode→Edit” (simply press 'E') to start editing at the vertex level.
  • Hold the 'Control' (or 'Ctrl') key down. Now if you click the left mouse button somewhere, it will create a vertice there, that will be part of the current curve. Create about 6 vertices in the 'Front View', as shown in the diagram.

Note: The vertices must be placed in order (either from top-to-bottom, or bottom-to-top)

  • Because you want the generated water drop to be closed both at the bottom and top, you need to make the X co-ordinate of the first and last vertices to a value of 0. To do this, double-click on the X co-ordinate of your first vertex in the 'Vertices List' on the right side of the screen. If you can't see the 'Vertices List', right-click on one of the lists on the right side of the window, and click on 'Vertices List'.

(Instead of double-clicking on the X co-ordinate, you can use UP/DOWN and LEFT/RIGHT arrow keys to navigate the editable item in the current list, hit TAB to switch between the lists, and hit ENTER (or RETURN) to edit the value.)

  • Type in '0' as the X co-ordinate. The first vertex you created should now be red (meaning it is the current vertex) and it should be exactly on the vertical line in the Front View. Do the same for the last vertex you created (at the bottom of the 'Vertices List').
  • You can play around with the curve if it isn't right. Right-click near a vertex to make it the current vertex, then drag it around by clicking the Left-mouse button in the position. Play around until the curve changes into your desired shape.
  • Type in '20' for the 'Density' of the curve and hit 'Enter'. This reduces the number of vertices that will be created for the curve.
  • You can also change the 'Curvature' if you want, which makes the curve more smoother.
  • Finally, click on “NURBS Curve→Make vertices from curve” (or hit 'J'), to convert the curve into a mesh (lots of vertices). A curve of 21 vertices should now be created. Notice that the vertices of the curve are blue because they are automatically selected, whereas the black vertices (for the curve's control points) aren't selected any more.
  • To look at it in the 3D View, click on “Edit Mode→Rotate” (simply press 'R') to change to Rotate mode. (The vertices in the 3D View will automatically be hidden in Rotate mode). Play around with it in the 3D View by dragging the Left or Right mouse buttons in the 3D View. To show a better looking object, click on “3D Settings→Gouraud & Z-Buffer” (simply press '5') for the best possible rendering.
  • Now that the body is selected, click on “Color→Set Triangle Colors” (simply press 'C') and select a nice water color.
  • To see a bigger 3D View, click on “View→Show3D View only” to see it much larger. You can also click on “Edit Mode→Zoom” (simply press 'Z') and drag the left mouse button up/down in the 3D View to zoom in/out.

Download Now

Support This Free Project

We use cookies to personalize and enhance your experience on our site. By using our site, you agree to our use of cookies.
  More information about cookies